A forum to show appreciation and respect for classic video game systems and games. Whether you're a modder, a programmer, or just a collector, this forum is about appreciating classic games and systems in a constructive community environment.
 
HomeHome  CalendarCalendar  FAQFAQ  SearchSearch  MemberlistMemberlist  UsergroupsUsergroups  RegisterRegister  Log in  

Share | 
 

 Pvm not working

View previous topic View next topic Go down 
AuthorMessage
mvsfan



Posts : 571
Join date : 2012-03-04

PostSubject: Pvm not working   Fri Jan 23, 2015 7:22 pm

i just bought another pvm. its the same model as my first one except it has a 20 inch screen. It was supposed to be working but it doesnt.

when i hit the power switch the power light turns green and i can hear the degauss coil. I also feel static on the screen if i put my arm up there.

but no osd ever shows up to tell me im on input 1 etc. its supposed to show the input as soon as you turn it on and i just get no signal at all.
Back to top Go down
View user profile
Drakon
Admin
Admin
avatar

Posts : 1607
Join date : 2012-01-25
Location : Canada

PostSubject: Re: Pvm not working   Sun Jan 25, 2015 9:39 am

I've never had a pvm. Working inside a crt can be dangerous if you don't know what you're doing.
Back to top Go down
View user profile http://16bitgamer.canadian-forum.com/
mvsfan



Posts : 571
Join date : 2012-03-04

PostSubject: Re: Pvm not working   Sun Jan 25, 2015 1:46 pm

Drakon wrote:
I've never had a pvm. Working inside a crt can be dangerous if you don't know what you're doing.

Oh, i know. I had a high voltage probe for discharging them and also to take readings but i havent been able to find it i havent seen it since i moved.

I havent touched the monitor yet and im aggrevated that i cant find it.

it was supposed to be a working monitor i just think something came loose in shipping.
Back to top Go down
View user profile
Drakon
Admin
Admin
avatar

Posts : 1607
Join date : 2012-01-25
Location : Canada

PostSubject: Re: Pvm not working   Sun Jan 25, 2015 5:54 pm

I just want you to be safe. Please don't attempt to fix it unless you have the proper tools, training, and certification.
Back to top Go down
View user profile http://16bitgamer.canadian-forum.com/
mvsfan



Posts : 571
Join date : 2012-03-04

PostSubject: Re: Pvm not working   Fri Feb 06, 2015 5:29 pm

i got the proper tool to discharge this and i took the chassis out of it.

Its not good news. On the main ic which has about 40 pins on each side, there is a crack running along every pin going down one side of the IC every trace is broken.
I could probably get it working again by reflowing the pins on that ic but since the board is cracked i dont trust that it wont just crack again. Its a large board with a lot of flex in it since its so thin. Its a lot thinner than most console pcbs.

i may have found someone who does repairs who can use some kind of a bonding kit to bond the pcb and restore the traces.

no idea what that would cost though.
Back to top Go down
View user profile
Drakon
Admin
Admin
avatar

Posts : 1607
Join date : 2012-01-25
Location : Canada

PostSubject: Re: Pvm not working   Sat Feb 07, 2015 12:48 pm

How close are the pins?  Is it possible to hand solder each one back together?  That's quite bad news indeed, probably stress from handling while shipping.

I've repaired a pcb in the past that bubbled and traces just burst. Was a bit of manual resoldering of traces using actual wires / metal legs.
Back to top Go down
View user profile http://16bitgamer.canadian-forum.com/
mvsfan



Posts : 571
Join date : 2012-03-04

PostSubject: Re: Pvm not working   Sat Feb 07, 2015 5:52 pm

I repaired an arcade pcb that had cut traces, where i just removed the soldermask and flowed solder between the gap. but the board itself wasnt cracked.

I think if i just do that in this case the board will crack more. Id have to glue it or something first and i dont know how the solder would react to the glue.
Back to top Go down
View user profile
Drakon
Admin
Admin
avatar

Posts : 1607
Join date : 2012-01-25
Location : Canada

PostSubject: Re: Pvm not working   Sun Feb 08, 2015 10:00 am

I hate cheap pcbs.
Back to top Go down
View user profile http://16bitgamer.canadian-forum.com/
Sponsored content




PostSubject: Re: Pvm not working   

Back to top Go down
 
Pvm not working
View previous topic View next topic Back to top 
Page 1 of 1
 Similar topics
-
» Working Table Equipments
» Does anyone know why the "Pupil" system isnt working
» Animal ID code not working?
» PlugY stopped working!!!
» Final Nights Disciplines Not Working

Permissions in this forum:You cannot reply to topics in this forum
 :: Projects / Showcase :: Works in Progress-
Jump to: